Make failed: No such file or directory

Hi,
I tried to install dgl from source to use the float16. However, when it make libxsmm,an error occour:

[  4%] Built target dmlc
[ 30%] Built target metis
: No such file or directory
: No such file or directory
================================================================================
LIBXSMM master-1.16.1-1534 (Linux@cpu-11)
--------------------------------------------------------------------------------
GNU Compiler Collection: gcc 7.3.1, g++ 7.3.1, and gfortran 4.8.5
C / C++ target: -msse4.2
Fortran target: -msse4.2
--------------------------------------------------------------------------------
--- LIBXSMM build log
make[3]: *** [include/libxsmm_config.h] Error 127
make[3]: *** Waiting for unfinished jobs....
make[3]: *** wait: No child processes.  Stop.
make[2]: *** [CMakeFiles/libxsmm] Error 2
make[1]: *** [CMakeFiles/libxsmm.dir/all] Error 2
make: *** [all] Error 2

Can you tell me how to fix it?Is there a pre-compiled DGL which support FP16 right now?

Hi,

Could you try cmake -DUSE_CUDA=ON -DUSE_FP16=ON -DUSE_LIBXSMM=OFF ..? This seems a bug we’d like to fix

Note that currently fp16 only supports CUDA, the result on cpu may be wrong

Thanks, I test it, it works. It seems that the bash scripts in the LIBXSMM Library end with \r\n in each line, which cause some problem in Linux. But I tried to delete the ‘\r’, it still can not be compiled. I dont know why. :rofl: